Nash Fiat Service
Incident Report for Nash
Resolved
This incident has been resolved. Please update your app to the latest version, 7.15 from Google or Apple store.
Posted Oct 18, 2021 - 18:57 UTC
Investigating
We received reports of users not being able to purchase, we are currently investigating.
Posted Oct 02, 2021 - 14:38 UTC
This incident affected: Fiat Services (Earnings & Buy/Sell).