Polygon Chain Degraded Performance
Incident Report for Nash
Resolved
The issue has been resolved.
Posted Jun 11, 2022 - 09:37 UTC
Identified
The issue has been identified and we are working on a fix.
Posted Jun 10, 2022 - 07:16 UTC
Investigating
We are currently experiencing some delays on Polygon chain that we are investigating.
Posted Jun 10, 2022 - 05:43 UTC
This incident affected: Wallet.