🛠️ Avalanche node
Incident Report for Nash
Resolved
The incident has been resolved.
Posted Dec 29, 2023 - 17:41 UTC
Investigating
You may face issues when interacting with Avalanche-based assets.
Posted Dec 28, 2023 - 16:52 UTC
This incident affected: Wallet and Fiat Services (Earnings & Buy/Sell).