Price Feed Incident
Incident Report for Nash
Resolved
The incident has been resolved.
Posted May 20, 2022 - 11:54 UTC
Investigating
We are currently experiencing Price Feed issues and are investigating.
Posted May 20, 2022 - 08:53 UTC
This incident affected: Price Feed.