MATIC/USDC trading pair issue
Incident Report for Nash
Resolved
This incident has been resolved.
Posted Feb 22, 2023 - 15:34 UTC
Identified
The problem has been identified: our liquidity provider currently has issues with MATIC.
Posted Feb 19, 2023 - 12:38 UTC
This incident affected: Exchange.