🛠️ Arbitrum node maintenance

Incident Report for Nash

Resolved

Maintenance complete.
Posted Sep 05, 2026 - 00:33 UTC

Monitoring

Maintenance has been completed and we are observing.
Posted Sep 04, 2026 - 22:07 UTC

Investigating

You might encounter problems using Arbitrum-based assets on our platform during the maintenance period. Rest assured, your funds are secure as Nash operates on a non-custodial basis.

Normal service will resume in next 24 hours.
Posted Sep 04, 2026 - 09:46 UTC
This incident affected: Wallet.