🛠️ Transaction history

Incident Report for Nash

Resolved

This incident has been resolved.
Posted Sep 11, 2025 - 12:24 UTC

Investigating

Your account transaction history may appear empty at the moment. Our team is investigating and working to restore normal access as soon as possible.

Rest assured, your funds are secure as Nash operates on a non-custodial basis. Normal service will resume once we resolve the incident.
Posted Sep 11, 2025 - 10:18 UTC
This incident affected: Wallet.