🛠️ Arbitrum node
Incident Report for Nash
Resolved
This incident has been resolved.
Posted Apr 23, 2024 - 05:28 UTC
Investigating
You might encounter problems using Arbitrum-based assets on our platform. Rest assured, your funds are secure as Nash operates on a non-custodial basis.

Normal service will resume once we resolve the incident.
Posted Apr 22, 2024 - 17:15 UTC
This incident affected: Wallet.