🛠️ ARBITRUM, BNB, Polygon node

Incident Report for Nash

Resolved

This incident has been resolved.
Posted Jul 11, 2025 - 11:09 UTC

Monitoring

We have implimented and fix and are monitoring.
Posted Jul 11, 2025 - 10:35 UTC

Investigating

You may face issues when interacting with BNB, Arb, Polygon-based assets. Rest assured, your funds are secure as Nash operates on a non-custodial basis.

Normal service will resume once we resolve the incident.
Posted Jul 11, 2025 - 05:14 UTC
This incident affected: Price Feed, Wallet, and Fiat Services (Earnings & Buy/Sell).