The KYC service is temporarily down.
Incident Report for Nash
Resolved
This incident has been resolved.
Posted May 25, 2022 - 17:36 UTC
Identified
We identified the issue and we are working on a fix, the deadline should be 30 minutes.
Posted May 25, 2022 - 17:10 UTC