Wallet access

Incident Report for Nash

Resolved

The issue has been resolved.
Posted Mar 26, 2023 - 09:43 UTC

Monitoring

We have implemented a fix and monitoring the results.
Posted Mar 26, 2023 - 09:15 UTC

Investigating

We are currently investigating the issue.
Posted Mar 26, 2023 - 08:25 UTC
This incident affected: Wallet.