Wallet access
Incident Report for Nash
Resolved
This incident has been resolved.
Posted Nov 07, 2024 - 09:10 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 07, 2024 - 08:46 UTC
Investigating
You might experience issues accessing the app, we are currently investigating.
Rest assured, your funds are secure as Nash operates on a non-custodial basis.
Posted Nov 07, 2024 - 06:00 UTC
This incident affected: Price Feed, Exchange, Wallet, and Fiat Services (Earnings & Buy/Sell).