Earn Service
Incident Report for Nash
Resolved
Incident has been resolved.
Posted Nov 03, 2022 - 08:44 UTC
Monitoring
A fix was implemented and we are monitoring the service.
Posted Nov 03, 2022 - 08:29 UTC
Investigating
Some users have reported issues with the Earn service, we are investigating.
Posted Nov 03, 2022 - 06:46 UTC
This incident affected: Wallet.