Blockchain Monitor issue
Incident Report for Nash
Resolved
This incident has been solved.
Posted May 18, 2023 - 10:37 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 17, 2023 - 22:22 UTC
Investigating
We are currently investigating this issue
Posted May 17, 2023 - 22:11 UTC
This incident affected: Exchange, Wallet, and Fiat Services (Earnings & Buy/Sell).