Wallet access

Incident Report for Nash

Resolved

This incident has been resolved.
Posted Apr 06, 2026 - 12:18 UTC

Monitoring

A fix was implemented and we are monitoring the results.
Posted Apr 06, 2026 - 11:45 UTC

Investigating

You might experience issues accessing the app, we are currently investigating.
Rest assured, your funds are secure as Nash operates on a non-custodial basis.
Posted Apr 06, 2026 - 11:19 UTC

Monitoring

A fix was implemented and we are monitoring the results.
Posted Apr 06, 2026 - 11:10 UTC

Investigating

You might experience issues accessing the app, we are currently investigating.
Rest assured, your funds are secure as Nash operates on a non-custodial basis.
Posted Apr 06, 2026 - 10:21 UTC
This incident affected: Wallet.