Transaction history and Wallet balances
Incident Report for Nash
Resolved
Incident has been resolved.
Posted Jun 22, 2023 - 11:55 UTC
Monitoring
A fix was implemented and we are monitoring the results.
Posted Jun 22, 2023 - 10:12 UTC
Investigating
There is an ongoing incident that affects users transaction history and wallet balances.
Posted Jun 22, 2023 - 09:34 UTC
This incident affected: Wallet.