Wallet access
Incident Report for Nash
Resolved
This Incident has been resolved.
Posted Jul 15, 2023 - 18:47 UTC
Monitoring
We have implemented a fix and are monitoring the results.
Posted Jul 15, 2023 - 15:11 UTC
Investigating
We are currently investigating the issue.
Posted Jul 15, 2023 - 14:48 UTC
This incident affected: Exchange and Wallet.