Compliance system upgraded
Incident Report for Nash
Resolved
This incident has been resolved.
Posted Dec 15, 2021 - 17:08 UTC
Monitoring
Nash has upgraded the KYC system. Please update your app from the relevant mobile store and declare a source of funds to keep using Earnings and our fiat gateway.
Posted Dec 06, 2021 - 15:00 UTC
This incident affected: Fiat Services (Earnings & Buy/Sell).